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Overview 
This note describes the recommended procedure to migrate a user calendar exported from Meeting 

Maker into FermiMail. The major steps are: 

1. Export the Old Calendar: Export the old calendar from Meeting Maker. 

2. Convert the Old Calendar: Convert the old calendar to a format that FermiMail can interpret. 

3. Complete the Converted Calendar: Open the converted calendar to polish and/or complete it. 

4. Import the Completed Calendar: Import the completed calendar into FermiMail for long-term 

use. 

5. Send Invitations to Personal Meetings (optional): Send invitations to meetings not in scheduled 

meeting rooms to put the meeting back onto the attendee’s calendars. 
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Requirements 
 This procedure requires the use of the windows Meeting Maker client and Outlook 2010. It also 

requires the use of a supported web browser to access the calendar converter. 

 This procedure requires Full Access to the FermiMail user calendar account in question. 

 This procedure does NOT require a FermiMail calendar to be empty before executing. Migrated 

events will be added to existing events. However, it is less risky to migrate into an empty 

calendar since deleting all events quietly is an option for recovery. 

Known Issues 
 If you are migrating a smaller number of events from MM to FermiMail, perhaps fewer than 20 

to 30 events, then we recommend that you simply recreate those events manually in FermiMail 

instead of using this procedure. This reduces the technical risk and invests your time in learning 

a tool you will use in the future. Learning this procedure will have no value once it is completed, 

and there is chance that MM will not export your calendar (silent failure) or that you will import 

your events into a secondary calendar (pilot error). 

 The following features are NOT exported by Meeting Maker, and thus are not treated in this 

procedure. They must be migrated or setup manually in FermiMail: 

o To Do items 

o Banners (multi-day all-day events) 

o MM Options – Private, Reminder, Reminder Interval, Flexible, Labels 

o User Interface configuration data – working hours, label values, proxy/delegate settings  
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A. Export the Old Calendar 

1. Open the Meeting Maker windows application.   

 

2. Login as yourself. 

 

a. (Migration Service only) To proxy as the User whose calendar is to be exported: select 

Proxy in the menu, and then More Proxies… 

 

 

b. (Migration Service only) Then select the user to be migrated. Click Open >>>, and OK. 
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3. Select the File menu, then select Export as ICalendar by Date… 

 

4. Set the From and To dates to capture as much or as little of your calendar as you want to 

migrate. This selects all Events that fall within this time window. If a recurring meeting has at 

least one occurrence in this time window, then all recurrences of the meeting are shown even 

those outside this time window. This example captures 3 years beginning 3/1/2012, which is 

recommended for user migrations. We strongly recommend exporting no more of your past 

calendar than needed due to issues silently preventing some older MM events to be exported. 
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5. Be sure that Export single file is checked. 

 

6. Select OK. MM may take a LONG time to generate a calendar file to save. We have observed 5-

10 minutes delay for some dense user calendars, during which the Meeting Maker window may 

appear to freeze. If this takes longer than 15 minutes, then you may have a corrupt Meeting 

Maker calendar event. 

a. Suspect Event in Meeting Maker Calendar: Set the From date closer to current date and 

retry. Step the From date closer to the current date and retry until you get an export file 

within a tolerable time. You may be able to identify the suspect event by process of 

elimination, comparing the list of exported events to the MM calendar content. 

 

7. Select a location and filename to save the file, then click Save. 

a. For this document, we assume the saved file is called MMCalendar-File1.ics  
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B. Convert the Old Calendar 
1. Open the FermiMail Room Calendar Converter application suited to your goal. 

a. User Migration Converter:  http://jabber3.fnal.gov/cgi-bin/calendartool?User  

Note the uppercase ‘U’ in User. You should see exactly the following before proceeding: 

 

2. Select Browse to select the calendar file to be converted. 

 

3. USER Choice: 

a. If you are migrated a User calendar, then do not select any checkboxes, OR 

b. If you want to produce a compact Event listing, then select Event list spreadsheet. The 

listing is of Events that would be output by the converter, so some filtering or 

translation may be applied. This listing can be used to drive a manual re-entry of Events 

or just to count the number of Events in the calendar file. 

 

4. Select Convert Calendar 

 

 

 

 

http://jabber3.fnal.gov/cgi-bin/calendartool?User
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5. If you experience a converter error dump (the purple screen shown below), then please copy 

the text shown and email it to exchange-proj@fnal.gov for timely resolution. You will not be 

able to proceed until this error is resolved. 

 

6. Select location to save the converted calendar file or event listing spreadsheet, click OK. 

a. For this document, we assume the saved file is called converted-File2.ics 

  

mailto:exchange-proj@fnal.gov
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C. Complete the Converted Calendar 
1. Open and login to Outlook 2010 on Windows 

a. (Migration Service only) Select an Outlook profile granting access to the user’s mailbox. 

If you do not see this profile selection box below, then STOP and ask for help. This 

procedure MUST be performed in the correct permissions state to avoid adding events 

to the migrator’s own calendar. The example shows a default profile (for the migrator’s 

own use) and two people whose calendars are going to be migrated. 

 

b. (Migration Service only) Authenticate using your own SERVICES username and 

password. 

c. We recommend that you disable spell-checking in Outlook. Frankly we have not figured 

out to do this yet for calendar events. We will adjust this step when we get it disabled. 

 

2. Disable cached-Exchange mode in Outlook 2010 

a. Go to File, and Account Settings 

b. Select the account settings you are using. In the example below, select cstestroom. 
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c. Uncheck Use Cached Exchange Mode 

 

d. Click Next, Finish, and Close. 

e. Restart Outlook (using this same profile if migrating someone else). 

You now can be assured that what you see in Outlook reflects what is stored on 

the server. This is critical if you are migrating a large number of events. Without this, the 

events may seem to have migrated in a few minutes, but are only in local cache which 

may take 30 minutes plus for the cache to sync to the FermiMail server. If you 

disconnected before then, many events would never get to the server. NOW, when you 

see the migration completed on your client, it is really uploaded to the server. You may 

undo this setting AFTER the migration is completed.  
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3. Open-to-view the file Converted-File2.ics 

a. Select the File tab, Open, and then Open Calendar: 

 

b. Select the file Converted-File2.ics 

c. Select OK. 

d. The calendar should load after a few seconds. You may want to close other calendar 

files in Outlook to provide screen space to view the converted file. 
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4. Add Event information that does not export from Meeting Maker: MM Options 

a. MM Options: Private, Reminder, Reminder Interval, Flexible, Labels 

b. Review Events in Meeting Maker that may require one or more of the “Meeting Maker 

Options” to be re-applied in the FermiMail Event. Then manually set that option. 

c. Select a Meeting Maker Event, and select its Options tab. 

 

 

 

 

Meeting 

Maker Event: 

Details Tab 

Meeting Maker 

Event: Options Tab 

 Reminder 

 Reminder Interval 

 Private 

 Flexible 

 Label(s) 
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d. Private: Private setting is visible in each Event in the calendar as well as on the Options 

tab of each MM Event. 

i. Identify Events that should be marked private, either from personal knowledge 

or by scanning the Meeting Maker calendar for key symbols in the event boxes. 

 

 

 

 

 

Private Event: Key symbol 

on left side 
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ii. Set Private on the Converted Event by right-clicking on the Event and selecting 

Private. When you view the Event details, you will see the padlock symbol 

highlighted. 

 

 

 

Set Private 

Private: Padlock 

highlighted 
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e. Reminder, Reminder Interval: Reminder settings are only visible on the Options tab of 

each Event in MM.  

iii. Identify Events that should be marked private, either from personal knowledge 

or by scanning the Meeting Maker calendar for key symbols in the event boxes. 

 

 
 

iv. Set Reminder and Reminder Interval settings using the interval selector. 

v. Then click Send Update 

 

vi. If you receive an error saying that there is no one to send this to, you should put 

yourself in the To… list. 

vii. If you receive more warnings about tallying responses, then please click through 

these to send the update. We are updating a calendar “offline” before saving, 

Reminder Interval Selector: 

Note Bell symbol 
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which Outlook is not accustomed to doing, so Outlook will treat some of our 

actions as probably in error. 

 

f. Flexible: Flexible setting is only visible on the Options tab of each Event in MM. We have 

not been able to determine a direct translation for MM Flexible in FermiMail. 

 

g. Labels: Labels are only visible on the Options tab of each Event in MM. Labels can be 

implemented by FermiMail Categories and/or Importance settings. Since labels have 

been applied by different users for different grouping or labeling purposes, we defer to 

users to apply these features as they see fit to accomplish their goals. If you select 

Categorize and then All Categories, you should be able to customize the Categories to 

implement whatever custom Labels you may have used in Meeting Maker. 

          

 

 

 

 

 

 

 

 

 

 



16 
 

5. Add Event information that does not export from Meeting Maker:  Banners 

a. Identify Banners in Meeting Maker that you wish to retain. 

 

b. Select Home, Week view (in Arrange group). Select-drag your cursor across the days you 

wish to create the Banner for and type in the title. 

 

6. Manually re-create EVENTS reported to use unsupported recurrence patterns. 

a. For any Events reported by the Converted as having an unsupported recurrence pattern, 

you will have to manually create these events in FermiMail. This was very rare in testing 

across many calendars, but technically can happen. Please see Recreating Unsupported 

Recurrence procedure for guidance. 

 

7. Visually inspect their FermiMail calendar against their MM calendar 

a. Remove obviously duplicated Events. 

viii. We expect that there will be some duplicates for Users who booked their own 

meeting in a scheduled Room. In this case, please work with the Room Admin to 

identify which meeting notice will be deleted and which will remain. 

b. Look for Events that are missing. 

ix. We expect that some Events will be missing if the scheduled room calendar has 

not migrated yet. If this is the case, then we recommend waiting for the Room 

A Banner in Meeting Maker 



17 
 

calendar migrations (Flag Day 1 and Flag Day 2) before worrying about whether 

or not to create placeholders for these events. 

x. We expect that some Events will be missing if a personal meeting has not been 

migrated by the User who created the meeting invite. If this is the case, then 

you may consider notifying the meeting invite creator, and in the meantime 

create a placeholder event in your calendar that you can delete later.  

 

8. Export the fixed converted.ics to the completed calendar FMCalendar-File3.ics 

a. Select File, then Save Calendar 

 

 

b. Set the filename (here, FMCalendar-File3.ics), but DO NOT SAVE YET. 

c. Select More Options… 
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d. Select Date Range: Whole calendar 

e. Select Detail: Full Details 

f. Select Advanced: Show>>> 

 

g. Check Include details of items marked private 

h. Check Include attachments within calendar items 

i. Click OK 

j. A dialogue box will open, “… include the calendar anyway?” Click Yes. 

k. Click Save 
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9. Close the fixed calendar 

a. Find the converted.ics calendar in left column, usually under “Other Calendars” 

b. Right-click on that calendar, select Delete Calendar 

 

c. Click Yes 
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D. Import the Completed Calendar 
1. Import the completed ICS file using Outlook 2010 on Windows 

a. Select the File tab, then Open 

b. Select Import 

 

c. Select Import an iCalendar File (.ics) or vCalendar file (.vcs) 
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d. Select the file, in this example FMCalendar-File3.ics, and then click OK. 

 

e. Select Import 

 

f. Your User calendar migration is complete. 

 

g. Please do not panic if you see only a few Events get imported. Recall that everyone’s 

user calendar is migrated in two separate efforts: Room calendar migration and User 

calendar migration. This only accomplishes the User calendar migration. The Room 

calendar migration will be performed centrally by Room Admins on Flag Day 1 

(Computing Sector – pilot) and Flag Day 2 (All of Fermilab). 

 

E. Send Invitations to Personal Meetings (optional) 
1. If you created a meeting (at least one other person invited) outside a scheduled meeting room, 

perhaps in your office or some ad hoc location, then you may wish to send a FermiMail 

invitation to the attendees to put this event onto their FermiMail user calendar. Otherwise, they 

may not see the meeting in FermiMail. 

a. To do this, just double-click on the meeting invite in question to open it. 

b. Select Send Update. 

c. (This will send a new meeting invite to all attendees.) 
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End Results 
 The content of the Meeting Maker calendar has now been imported into FermiMail. You may 

begin to maintain these Events in FermiMail going forward. 

 You may want to re-enable cached Exchange mode if you had it set before. 

 

 For you to have a complete calendar, in general, both your User calendar and all (meeting) 

Room calendars must be migrated. These instructions assume that Room calendars have already 

been migrated. If you have migrated your User calendar before the Room calendars, you will 

NOT see all the events in your calendar yet. 

 Meeting invites are not re-issued in this procedure. If you wish to issue meeting (re-)invites for a 

meeting you just imported, then you may make a modest change to the meeting, perhaps add a 

little text to the Description, and then “Send Update” to the meeting invitees in the To list. 

 Due to filtering of Events, possible pre-existing Events, and recurrence splitting, it is very hard to 

use an Event count to reliably check whether the migration was successful. 

 

 If your import goes very badly, there are options to delete your calendar in FermiMail all at once 

without creating “canceled meeting” and “reject invitation” email notices to all others. Please 

consult a FermiMail expert. 


